New Collection post: Exposing Hacks for ZSTD -compressed Metztli Reiser4 / Debian Buster bps Linux 5.5.caxtolli∙omome and initramfs.

So yes, this post was about utilizing the last Debian packaging for Linux kernel 5.5 series, i.e., 5.5.13, and applying upstream delta patches to bring it up to 5.5.15. However, as I was writing this post kernel 5.5.16 became available --which is what I will aim to patch and, subsequently, I will 'Add support for ZSTD-compressed kernel and initramfs' via a customized patch. And lastly, I will apply reiser4 for 5.5.5 patch --which still applies smoothly over kernel 5.5.15, and hopefully 5.5.16, and build our hacked kernel.

Meltdown and Spectre Chip Vulnerabilities Target Cloud Providers.

cihuatl meltdown
Meltdown and Spectre
On January 06, 2018, Metztli IT released Metztli Reiser4 Linux 4.14.12-1 for Debian stretch-backports on AMD64 architecture -- which extensions are also licensed by Intel -- that addresses Meltdown (CVE-2017-5754) and Spectre (CVE-2017-5753 / CVE-2017-5715)...

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer